Search

Vista Compatibility


LF Express v7.1
No known issues.

LF Enterprise, Professional, Academic v7.1

  • Installing VS2003

  • Installing VS2003 and LF v7.1 should proceed normally, however during the installation process, a number of confirmation dialogs and compatibility warnings will appear. If you proceed, the software will install. It is recommended that you install the VS2003 SP1.

  • Starting VS2003

  • VS2003 should be run by a user belonging to the administrator group, and should be started by right clicking and selecting "Run as administrator". A shortcut can be created to do this by selecting the "Advanced" button from the Shortcut property page.

  • Installing and configuring IIS (Fortran.Net only)

  • 1. On the Start menu, choose All Programs then Accessories then Run.
    2. In the Open dialog box, type appwiz.cpl, and then click OK to open the Uninstall or change a program dialog box; you can also access this dialog box from the Control Panel.
    3. In the left pane of the Uninstall or change a program dialog box, choose Turn Windows features on or off.
    4. In the Windows Features dialog, check the Internet Information Services (IIS) checkbox.
    5. Expand IIS, then expand Web Management Tools, then expand IIS Management Compatibility. Select the IIS6 Metabase and IIS 6 configuration compatibility checkbox.
    6. Choose OK to install IIS.
    7. Close the Uninstall or change a program dialog box.

  • Installing Framework 1.1 (Fortran.Net only)

  • Installing Framework 1.1 should proceed normally. Also install the .NET Framework Version 1.1 Service Pack 1 and ASP.NET Security Update for .NET Framework 1.1 SP1.

  • Compiler configuration

  • The Fortran 95 compiler should run without any problems. In order to run the Fortran.Net compiler, a configuration file must be installed. The FAQ Making LF 7.1 .NET Work Side by Side with .NET 2.0/VS2005 describes how to do this. The procedures in the FAQ works for Framework 3.0 as well as Framework 2.0.

  • Microsoft maintains a list of known issues when running VS2003 on Vista. In addition to these issues, Fortran.Net has an issue with Web applications and services not working. We are currently looking for a fix to this problem, and are including instructions here on installing IIS. Note that IIS only needs to be installed if you plan on creating Web applications.
  •